古いバージョンのnpmパッケージをインストールします

互換性の問題を解決するのに役立つ可能性のある古いバージョンのnpmパッケージをインストールする方法を学ぶ

npmパッケージの古いバージョンを使用してインストールできます@構文:

npm install <package>@<version>

例:

npm install cowsay

installs version 1.3.1 (at the time of writing).

次のコマンドでバージョン1.2.0をインストールします。

npm install [email protected]

グローバルパッケージでも同じことができます。

npm install -g [email protected]

以前のバージョンのパッケージをすべて一覧表示することもできます。あなたはそれを行うことができますnpm view <package> versions

❯ npm view cowsay versions

[ ‘1.0.0’, ‘1.0.1’, ‘1.0.2’, ‘1.0.3’, ‘1.1.0’, ‘1.1.1’, ‘1.1.2’, ‘1.1.3’, ‘1.1.4’, ‘1.1.5’, ‘1.1.6’, ‘1.1.7’, ‘1.1.8’, ‘1.1.9’, ‘1.2.0’, ‘1.2.1’, ‘1.3.0’, ‘1.3.1’ ]

私の無料ダウンロードNode.jsハンドブック


その他のノードチュートリアル: